I suggest you...

Fix bug where Choosy is disabled on startup

Choosy is installed and working beautifully, and set as standard browser in Safari. Until I restart... Almost every time I restart (I'd say 80-90 % of the time), Choosy has disabled itself in the System Preferences and Safari has taken the position of default browser.

So the first thing I need to do when I restart the computer is to go to System Preferences, click OK in the "Choosy is disabled" dialogue box (that's a very annoying little box), and check "Enable Choosy for links" and Enable Choosy for HTML files".

This was the case in the beta versions and is still the case after I upgraded to 1.0.

Very annoying.
Probably not intentional.

75 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  Admingeorgebrock (Admin, Choosy) responded  · 

    I’m still looking into this, but it seems to have more to do with the OS than Choosy.

    This issues can sometimes be related to using File Vault. If you are using File Vault you could try disabling it. See this post on SuperUser for more information:
    http://superuser.com/questions/2735

    If you’re not using File Vault there are some suggestions about resetting your Launch Services settings in this Apple Forum thread: http://discussions.apple.com/message.jspa?messageID=8965818

    If none of that helps, please leave a comment letting me know.

    Sorry for the inconvenience.

    29 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Jules Piccotti commented  ·   ·  Flag as inappropriate

        I have the same issue, and tried all the suggested actions without success. I keep finding choosy helper disabled at every restart. FileVault is disabled.

      • robert Granger commented  ·   ·  Flag as inappropriate

        I think that I am, it doesn't always start on a couple of my macs.
        10.12.2, version choosy 1.1. helper doesn't seem to start.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I'm assuming nothing is happening on this since its all old but I'm still seeing the issue now and its bloody annoying

      • Sergey commented  ·   ·  Flag as inappropriate

        I want to second that. None of the proposed solutions helped and since other "Helper" utilities for tools like Things, ClipMenu and Palua are working fine I still think it is related to application.

      • TD commented  ·   ·  Flag as inappropriate

        George - it has not made any difference. Every time I reboot my machine choosy is disabled and I have to manually re-enable it.

      • fort commented  ·   ·  Flag as inappropriate

        This still happens to me every time I restart my machine. Is there a fix in the works?

      • doonyakka commented  ·   ·  Flag as inappropriate

        Any chance of seeing a fix for this? It's still happens every time I restart, and it's incredibly annoying.

      • Ben428 commented  ·   ·  Flag as inappropriate

        I am also having this problem on OS X 10.8. I am not running FileVault. I have reset Launch Services. Is this still under review? It seems to make Choosy unusable in 10.8.

      • doonyakka commented  ·   ·  Flag as inappropriate

        Still having this problem. File Vault is disabled and I've tried resetting my Launch Services.

      • Rick Carter commented  ·   ·  Flag as inappropriate

        I had problems on OS X 10.6.8 with no FileVault and now 10.8.2 and then 10.8.3 *with* FileVault (which is required as this is a work laptop). I'll try the others' suggestion about Default Browser checks in mine.

      • Mike Foley commented  ·   ·  Flag as inappropriate

        I'm seeing this as well. MBP running 10.8. Any update on a fix? Love Choosy but this is annoying..

      • Ted commented  ·   ·  Flag as inappropriate

        I have a similar problem where Choosy stops after leaving machine idle. Every morning I must turn Choosy off, and turn back on.

        MBP running 10.7.3

      • Mark Andrus commented  ·   ·  Flag as inappropriate

        I played around with my browser's setting and seem to have fixed it, I made the following changes to each of my browsers preferences.

        Safari: Select Choosy as the default browser.

        Firefox: Uncheck the "Always check to see if Firefox is the default browser on startup" (on the Advanced tab under General)

        Chrome: Make sure that Chrome is not set as your default browser. (If it is then you need to enable Choosy then quit Chrome then reopen it up again, and when the yellow notification bar asks you to set Chrome as your default browser make sure you click the button to "Never ask again")

        I am fairly certain that the Chrome setting was the culprit for me because once I reset it as the default browser it disables Choosy. Anyway, if you set all three of the browsers to the above settings then it should never disable again and Choosy will work great!

        Hope this helps...

      • Mark Andrus commented  ·   ·  Flag as inappropriate

        I am still having this very annoying issue, and as it seems I am not alone. Is there anyone on the Choosy team looking into this problem? Please address soon!

      • Reuben commented  ·   ·  Flag as inappropriate

        +1 same problem. File vault is disabled. Have repaired permissions. Have even uninstalled and reinstalled choosy.

      • David commented  ·   ·  Flag as inappropriate

        VERY ANNOYING. This bug happens time & time again for me! Please fix this issue. Also I am not using File Vault either.

      • Mark Andrus commented  ·   ·  Flag as inappropriate

        This bug happened again today and this problem is starting to drive me away from using Choosy at all, please address this issue. Also I am not using File Vault so doesn't seem to be the culprit.

      ← Previous 1

      Feedback and Knowledge Base